-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (19) .- Knowledge Base (1) . 

qTwitter

   0.10.0  

Qt Chat Application

Score 87%
qTwitter
zoom


qTwitter
zoom


qTwitter
zoom


Blog:  http://qtwitter.ayoy.net
other:  Link
Minimum required   Qt 4.x
Downloads:  9690
Submitted:  Feb 9 2009
Updated:  Nov 18 2009

Description:

qTwitter is an application interacting with microblogging services, such as Twitter, Identi.ca and others based on StatusNet application (former laconica). It aims to be as compact as possible still providing outstanding usability. Since it's a Qt-based application with no other dependencies, it works wherever Qt does, i.e. Windows, Mac OS X and vast variety of Linuxes and Unices supporting X11 (including Nokia's Maemo platform).

Features' summary as for v0.10.0:
- OAuth-based authentication scheme for Twitter accounts,
- support for Twitter, Identi.ca and StatusNet for:
* friends and mentions (@-replies) timeline,
* posting, replying, retweeting, deleting and (dis)favoring statuses,
* downloading, sending and deleting direct messages,
- secure (SSL encrypted) connection to Twitter and Identi.ca,
- support for working with multiple accounts at the same time,
- storing statuses lists between sessions,
- automatic #hashtagging and URL shortening via 9 different services,
- full interaction with TwitPic API, allowing for easy one-click image uploading and posting updates,
- system tray notifications (via Plasma and Growl),
- customizable statuses list length and look (via the use of themes),
- automatic checking for updates,
- in-session passwords storing (can be disabled),
- HTTP proxy support,
- being recognized as a source of updates,
- translation to 10 languages in run-time (sorry for my poor Catalan, I appreciate any help here :) ).

See CHANGELOG for details.

If you wish to report an issue, request a feature, provide a translation (yay!) or just give any kind of feedback concerning qTwitter, the easiest way is to visit its bug tracking system site at:

http://ayoy.lighthouseapp.com/projects/27230-qtwitter/tickets?q=all

If you wish, you can also contact me either via e-mail (d AT ayoy DOT net) or at Identi.ca (http://identi.ca/ayoy).

Happy twitting!

The qTwitter team

[size=4]IMPORTANT:[/size]

Since 0.8.0 qTwitter depends on QOAuth library, available separately at http://www.qt-apps.org/content/show.php?content=107420. In short, apart from Qt you will need QCA and qca-ossl plugin for qTwitter to work. You'll find all the needed details at that link. The download links below contain qoauth packages as well. Please install qoauth prior to qtwitter. Starting from 0.8.3 qTwitter uses qoauth-1.0. Thanks!




Changelog:

(2009/11/18): adding packages for Maemo (Diablo - N810)
v0.10.0 (2009/11/01):
- merging friends timeline with mentions (@-replies) timeline,
- fixed notifications - now notify about new statuses (NOT unread ones) and display unread statuses count,
- improved URL shortening (all urls at one go, customizable shortcut, pluggable),
- automatic #hashtagging,
- fixes in parsing links in statuses (by Stephan Beyer),
- initial plugin architecture (subject to change),
- improvements in build system (detecting correct libdir on *NIXes and automatic generation of translations),
- code cleanup in Twitter API library (by Stephan Beyer).
v0.9.2 (2009/10/01):
- SSL encryption for connections to Twitter and Identi.ca (#75),
- fixed incomplete Norwegian translation (#74),
- fixed minor bug with disappearing Identi.ca URL when removing all of its accounts.
v0.9.1 (2009/09/30):
- in KDE4: notifications displayed using Plasma notification services,
- on *NIX: prevented spawning multiple instances of the application (#73),
- on OSX: now showing icon in Dock,
- added look&feel customisation options, like visibility of the tray icon (#70)
and behavior of the close button,
- added crash detection, bug reporting link and reseting configuration to the working state (#68),
- removed (not really working well) settings compatibility with older versions,
- removed non-OAuth app version (#66),
- added Norwegian translation (by Egil Hanger),
- lots of minor fixes as usual.
v0.9.0 (2009/09/07):
- provided support for custom StatusNet (former laconica) services (#60),
- left/right arrow key goes to next/prev unread status (by Stephan Beyer),
- status author's display mode made customizable (name, nick or name+nick),
- added parsing StatusNet groups (!sth),
- fixed unwanted 'new statuses' on the bottom of the list (#63),
- applied system palette to status edit field (#61),
- added Czech translation (by DragonJake - #62),
- added b.oooom.net URL shortening (by dubkat - #57),
- improved storing data between sessions,
- improvements in Twitter API library,
- numerous minor UI, performance, architectural and build system fixes.

....full changelog available within the source package.




LicenseLGPL
Source(qtwitter-0.10.0-src.tar.gz)
Mac OS X(qtwitter-0.10.0.dmg (Tiger/Leopard/Snow Leopard))
MS Windows(qtwitter-0.10.0-setup.exe)
Ubuntu(0.10.0 debs for Jaunty/Karmic i386 and amd64)
Debian(0.9.0 debs for Lenny amd64)
Gentoo(emerge net-im/qtwitter)
Fedora(0.10.0 rpms for Fedora 11 i586 and amd64)
Mandriva(qtwitter-0.5.0-1.1.i586.rpm)
SUSE(qtwitter-0.5.0-1.1.i586.rpm)
Arch(qtwitter-0.10.0 PKGBUILD)
other(Maemo (Diablo - N810))
Send to a friend
Subscribe
Other  Apps  from ayoy
Report inappropriate content



goto page: prev   1  2  3 

-
.

 compile error

 
 by mxttie on: Jan 7 2010
 
Score 50%

hi, when trying to compile on windows, I get the following error
==============================
T:\source\qtwitter-0.10.0>mingw32-make
cd translations\ && mingw32-make -f Makefile
mingw32-make[1]: Entering directory `T:/source/qtwitter-0.10.0/translations'
mingw32-make -f Makefile.Release
mingw32-make[2]: Entering directory `T:/source/qtwitter-0.10.0/translations'
mingw32-make[2]: *** No rule to make target `.qm-removed', needed by `../build/l
oc/qtwitter_ca_ES.qm'. Stop.
mingw32-make[2]: Leaving directory `T:/source/qtwitter-0.10.0/translations'
mingw32-make[1]: *** [release] Error 2
mingw32-make[1]: Leaving directory `T:/source/qtwitter-0.10.0/translations'
mingw32-make: *** [sub-translations-make_default-ordered] Error 2
==============================
do i need to install something additionally?


Reply to this

-

 Re: compile error

 
 by ayoy on: Jan 8 2010
 
Score 50%

Please make sure that you have the latest code from git. I remember fixing something like this after 0.10.0 release, but I might be mistaken. I don't have Windows machine so I can't test it at the moment :/


Reply to this

-

 Re: Re: compile error

 
 by mxttie on: Jan 8 2010
 
Score 50%

I downloaded the latest git version from github and tried again, I have the same error. I am not so suprised though.. The only reference to .qm-remove is in translations.pro:
================================
unix {
system(mkdir -p $${qmpath} && touch $${qmfiles})
translations.files = $${qmfiles}
translations.path = $${SHARE_DIR}/loc
INSTALLS += translations

removeqm.input = qmfiles
removeqm.output = .qm-removed
removeqm.variable_out = PRE_TARGETDEPS
removeqm.commands = rm -f ${QMAKE_FILE_IN} && touch ${QMAKE_FILE_OUT}
removeqm.name = REMOVEQM ${QMAKE_FILE_IN}
removeqm.CONFIG += no_link combine explicit_dependencies
QMAKE_EXTRA_COMPILERS += removeqm
}

updateqm.input = TRANSLATIONS
updateqm.output = $${DESTDIR}/${QMAKE_FILE_BASE}.qm
updateqm.variable_out = PRE_TARGETDEPS
updateqm.commands = $${LRELEASE} ${QMAKE_FILE_IN} -qm ${QMAKE_FILE_OUT}
updateqm.depends = .qm-removed
updateqm.name = LRELEASE ${QMAKE_FILE_IN}
updateqm.CONFIG += no_link
QMAKE_EXTRA_COMPILERS += updateqm
====================================
so updateqm depends on .qm-removed, although this target does not exist in any other build file..


Reply to this

-

 Re: Re: Re: compile error

 
 by ayoy on: Jan 9 2010
 
Score 50%

This might be fixed now, please test :)


Reply to this

-

 qt 4.6 dependency?

 
 by mxttie on: Jan 9 2010
 
Score 50%

hi again, but now from linux ;)
I was trying to compile the git version (using qt 4.5.3) and see it errors on some new qt function:
==========================
g++ -c -pipe -O2 -fomit-frame-pointer -fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -Wall -W -D_REENTRANT -DSHARE_DIR=\"/usr/share/qtwitter\" -DHAVE_OAUTH -DPLUGINS_DIR=\"/usr/lib/qtwitter/plugins\" -DQT_NO_DEBUG -DQT_DBUS_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/default -I. -I/usr/include/QtCore -I/usr/include/QtNetwork -I/usr/include/QtGui -I/usr/include/QtXml -I/usr/include/QtDBus -I/usr/include -I../../qtwitter -I../tmp -I../twitterapi -Isrc/dbus -Isrc/oauth -Isrc/pluginmgr -Isrc/accounts -Isrc/qticonloader -Isrc -I/usr/include/QtOAuth -I/usr/include/QtCrypto -I../tmp -I../tmp -o ../tmp/core.o src/core.cpp
src/core.cpp: In member function ‘void Core::setImageForUrl(const QString&)’:
src/core.cpp:516: error: no matching function for call to ‘QPixmapCache::find(const QString&, QPixmap*)’
/usr/include/QtGui/qpixmapcache.h:58: note: candidates are: static QPixmap* QPixmapCache::find(const QString&)
/usr/include/QtGui/qpixmapcache.h:59: note: static bool QPixmapCache::find(const QString&, QPixmap&)
make[1]: *** [../tmp/core.o] Error 1
==========================

So I guess you are depending on qt 4.6 now? you might want to update the docs :)


Reply to this

-

 Re: qt 4.6 dependency?

 
 by ayoy on: Jan 9 2010
 
Score 50%

That's true, git version requires Qt 4.6 now. Thanks for bringing this up, I'll update the info. Plus I'll try to figure out the Windows issue as soon as I get to any Windows box. In the meantime, patches are welcome :)


Reply to this

-

 Re: qt 4.6 dependency?

 
 by ayoy on: Jan 9 2010
 
Score 50%

Hey, actually I pushed a small fix to restore compatibility with Qt 4.5 (hopefully, as I can't test it atm since I don't have Qt 4.5). Please give it a try one more time if you can, thanks!


Reply to this

-

 memory leaks

 
 by reonaydo on: Apr 11 2010
 
Score 50%

qtwitter has memory leaks
Quote:

tuupic@home ~ $ ps uxaww | grep -v grep | grep qtwitter
tuupic 12032 0.0 4.0 188880 84896 ? Sl Apr09 2:47 /usr/bin/qtwitter
tuupic@home ~ $

Some weaks ago qtwitter used more than 200 Mb memory. But after start it use about 25 Mb


Reply to this

-
.

 Logout cancelled by qTwitter!!

 
 by fadnix on: Jun 7 2010
 
Score 50%

I love your app, it runs great under Fedora 12 & 13 with KDE4. However, when i try to shutdown my machine while the application window is up (not minimized) it will show this message "Logout canceled by '/usr/bin/qtwitter' and qTwitter window will disappear however the small icon in the system tray is still showing but not responsive and the system does not shutdown and i have to do the shutdown again. But if i minimize the qtwitter window first it will shutdown without any issue. I don't know why it does that, but i hope it is easy to fix.


Fahad
Reply to this

goto page: prev   1  2  3 

Add commentBack






-
Cool Sites
QtitanDataGrid Advanced Grid for Qt

 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About Qt-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2006-2014 Qt-Apps.org Team  
All rights reserved. Qt-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.
Qt is a trademarks of Nokia